CentOS-7でepelから導入したClamAVのパターン更新エラー

10月に入り、久々にCentOS-7の環境が必要になり起動したところ、次のようなエラーがメールで届いた。

Subject:  Cron <root@HOSTNAME> /usr/share/clamav/freshclam-sleep > /dev/null

ERROR: Database update process failed: Forbidden; Blocked by CDN
ERROR: Update failed.

環境は以下の通り。

$ cat /etc/redhat-release
CentOS Linux release 7.9.2009 (Core)

$ rpm -qa | grep -i clamav
clamav-filesystem-0.103.11-1.el7.noarch
clamav-lib-0.103.11-1.el7.x86_64
clamav-0.103.11-1.el7.x86_64
clamav-update-0.103.11-1.el7.x86_64

clamav* のパッケージは、epelリポジトリから導入したもの。


この通知は、ClamAVのパターン更新が行われた際に、古いバージョンの ClamAV クライアントがブロックされたことで発生する模様。

clamav-0.103は、以下で 2025/9/14 までデータベースのダウンロードが許可されているアナウンスがあった。
ClamAV® blog: End of life (EOL) policy change, 0.103 one year extension, 0.105 past end of life


日程は少しずれているが、上記のアナウンスの通り、クライアントが古いことが原因。

問題の処理は以下に設定されており、cronから実行されている。

$ cat /etc/cron.d/clamav-update
## Adjust this line...
MAILTO=root

## It is ok to execute it as root; freshclam drops privileges and becomes
## user 'clamupdate' as soon as possible
0  */3 * * * root /usr/share/clamav/freshclam-sleep > /dev/null

もし、何らかの理由で、古いデータベースのままClamAVを使い続けたいのであれば、上記のcron実行をコメントアウトすれば良い。

このファイルは、以下のパッケージに含まれている。

$ rpm -qf /etc/cron.d/clamav-update
clamav-update-0.103.11-1.el7.x86_64

ClamAVを使わないのであれば、clamavをアンインストールする。

# yum remove clamav*